Subject: Problems booting NetBSD

From: Gordon Hundley - CIX Staff <[email-masked]>
Date: Thu, 14 Oct 93 12:03 GMT0BST-1

Okay, I have repartitioned my hard disk, booted into Workbench and
transferred the necessaries over the wire to the AmigaDOS partition.
I have written the root file system to its proper place, and I have
done the magical 'loadbsd vmunix'. Here's what it says:

All rights reserved.

NetBSD 0.9 () #644: Thu Sep  9 22:57:27 MET DST 1993
  [email-masked]:/home/usr/src/sys/arch/amiga/compile/AMIGA
AMIGA/A3000 MC68030 CPU+MMU, 25Mhz MC68882 FPU)
real mem = 4194304
avail mem = 2228224
using 51 buffers containing 417792 bytes of memory
dma0: A3000 32bit DMA
scsi0: scsi id 7
a3000scsi0 [1/1]
scsi0: target 2 now synchronous, period=248ns, offset=8.
sd2: QUANTUM LP52S  950509405 rev , 102171 512 byte blocks
sd2 at a3000scsi0, slave 2
scsi0: target 6 now synchronous, period=248ns, offset=8.
sbic_wait TIMEQ @1179 with asr=x0 csr=x41
Realtime clock A3000
rtclock0 [1/4]
par0 [1/6]
grf0: 704 x 464 monochrome custom chips display
grf0 [1/7]
ser0 [1/3]
root device? sd6a
bad/missing unit number
root device? sd6a
bad/missing unit number
root device? sd6a
bad/missing unit number
root device? sd6a
bad/missing unit number
root device? sd6a
bad/missing unit number
root device? sd6a
bad/missing unit number
root device? sd6a

bpf: sl0 attached
bpf: sl1 attached
bpf: sl2 attached
bpf: sl3 attached
bpf: ppp0 attached
bpf: ppp1 attached
bpf: ppp2 attached
bpf: ppp3 attached
bpf: lo0 attached
panic: cannot mount root
hit any key to boot/dump...
>syncing disks... trap: bad kernel access at 15
trap type 8, code = 2000715, v = 15
pid = 0, pc = 00019E02, ps = 2004, sfc = 0001, dfc = 0001
Registers:
             0        1        2        3        4        5        6         7
dreg: 00000000 0000000A 00000100 000B41C8 00000000 07CF35C4 0006E000 000000003
areg: FFFFFFFF 01DE8400 00000000 00000000 00083C1C 00000440 FFFFFF6C 0EFFFFFFC

Kernel stack (FFFFFEA2):
FFFEA2: 00059844 FFFFFF02 00000000 000597CA 00000008 02000715 00000015 00000100
FFFEC2: 000B41C8 00000000 07CF35C4 0006E000 00000003 00000000 00000000 00083C1C
FFFEE2: 00000440 0000179E 00007530 FFFFFF6C 000004E8 00000008 02000715 00000015
FFFF02: 00000000 0000000A 00000100 000B41C8 00000000 07CF35C4 0006E000 00000003
FFFF22: FFFFFFFF 01DE8400 00000000 00000000 00083C1C 00000440 FFFFFF6C 0EFFFFFC
FFFF42: 00002004 00019E02 A0080EEC 07156002 70010000 00150000 00150000 00404280
FFFF62: 04400000 00000009 6008FFFF FF7C0001 B6240000 00000000 CE86FFFF FF9C0005
FFFF82: 5F540009 60080000 00000000 00000000 0100000B 41C80000 CE86FFFF FFA40005
FFFFA2: 602EFFFF FFC40000 CC240000 01000000 CBBB0000 CBB00000 428B0000 20840001
FFFFC2: A662FFFF FFF40000 46CA0000 428BFFFF FFFF0000 00000EFF FFFC07C3 3F9A000A
FFFFE2: 658507C3 3F3C0000 00000000 00000000 000007C0 08100000 09020000
panic: MMU fault
hit any key to boot/dump...

Further to this, I applied the binpatches for disabling syncing and dma,
and that cleared up a couple of error messages. It still fails to find
root, dumps and panics. I've tried all the obvious stuff, like using a
single drive configuration, different SCSI addresses, older kickstarts.
I've checked using BFFSFileSystem to make sure that everything was
there, which indeed it was.

The only clue I have is that it may have something to do with the
loadbsd software. It comes up with a warning saying that it is looking
for version 46 of the ixemul.library and I could only find 45 out there
on the net. The files I found using archie which purported to be version
47 revealed themselves as having a version 24 number in them despite the
recent build date. They cause a bus error anyway.

Any of you kernel gurus able to debug the above or just _know_ whats
wrong? Anybody know where I get ixemul.library version 39.46?

Thanks,

Gordon.

---

From: [email-masked] (Markus Wild)
Date: Thu, 14 Oct 1993 18:06:51 +0100 (MET)

> sbic_wait TIMEQ @1179 with asr=x0 csr=x41

So disable sync for that drive. I'm not going to explain this again and 
again...

> bad/missing unit number

Get the new loadbsd binary, the old one can't load #644.

> for version 46 of the ixemul.library and I could only find 45 out there

Nah, that's harmless. But do get the new version.

-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH

---

From: Darren Reed <[email-masked]>
Date: Fri, 15 Oct 1993 05:23:07 +1000 (EST)

[...]
> So disable sync for that drive. I'm not going to explain this again and 

Is it possible to make this bit more intelligent and have it fail over to
async if it receivies this error when trying to setup sync SCSI ?

darren