Subject: X11 compile attempt

From: [email-masked] (Markus Illenseer)

Hi. While trying to set up a very first X11 environment i have problems
to compile the libraries with the provided mit-imake.

(Not to speak from the patches, i was not able to apply fix-16 to fix-25
yet).

I got a working amigabsd.cf and the imake-tool does recognize Amiga-NetBSD,
but the generated Makefiles do not work entirly.

For example the 'ln' command does not work correctly to install the
include-files in ../mit/X11:

(part: make includes)
including in ./include...
[: .././X11/: binary operator expected
+ /bin/sh .././util/scripts/mkdirhier.sh .././X11/ .
+ cd .././X11/ .
+ rm -f DECkeysym.h
+ ln -s ../ . /./include/DECkeysym.h .
ln: ./..: cannot overwrite directory
ln: ./.: cannot overwrite directory
*** Error code 1

The arguments for ln are messed up, as you can see. This looks like
a missing or mangled variable in the Makefiles, but i couldn't detect any.

Further on, either the ranlib or the ar command do not
generate a usefull *.a library which yields into a problem
when compiling the Xlibs.

(part: make depend in ../mit/lib/X)
rm -f  makedepend
gcc -fpcc-struct-return -o makedepend include.o main.o parse.o pr.o cppsetup.o -
O     ../.././lib/Berk/libXbsd.a 
gcc: ../.././lib/Berk/libXbsd.a: No such file or directory
*** Error code 1

-------

Anyone have any idea what might be wrong ? I haven't changeg anything
serious yet, just added amigabsd.cf and the needed #ifdef amiga in
the Imake-scripts.

If anybody is familar with porting (or even compiling) X11 on other 
platforms, i would like to send him the .cf files :)

-- 
Markus Illenseer

---

From: Markus Landgraf <[email-masked]>

(part: make includes)

Seems to me that there are some invalid settings in the .tmpl files
for imake. I guess something like INCLUDESRCDIR or so is wrong.
Furthermore there are two different ways to use imake: with and
without -DUseInstalled. Select which one is appropriate. 

Is the library path correct ? Perhaps you have to add -L ../../lib/Berk
to the Library options somewhere in the imake configuration.

------------------------------------------------------------------------------
Landi#2
[email-masked]
"The only time when I'm easy is when I'm killed by death"
"If You got the power, that don't mean You got the right"
                                                          I. Kilmister
------------------------------------------------------------------------------