Subject: HELP! "Tell root to fix this someday"

From: Matthias Kirschnick <[email-masked]>

Hello,

a few weeks ago I asked for help on my "trapsignal()"-problem. No
one send me any hint, so I went on alone.
Now I've found some interesting new messages written by /bin/sh to
the console device (using cryo_debug = 1, ac_debug = 1, ....).

NetBSD 0.9()#644
[...]
changing root dev to sd0a
[...]
net-init round robin schedcpu enable rtclock mount root
VFS_ROOT swapinit siginit
entering init: vm_allocate-text init: vm_allocate-stack init: copyout-text init: copyout-flags init: r
sigreturn: pid 3 scp 423a8                         [the "r" ist the last character in the line above!]
blo.k o. fr.e l.st .lob.ere.                                     [the dots are some weird characters!]
Tel. ro.t t. fi. th.s s.med.y
Sto.pin. my.elf...sendsig(3): sig 6 scp efff9a4 fp efff7ae scsp efff9c0 sc_ap efff7be
sigreturn: pid 3 scp efff9a4
sigreturn(3): sc_ap efff7be flags 6
sigreturn(3): returns.

trapsignal(3, 11, 240, f0, 385d0)
trapsignal(3, 11, 240, f0, 385d0)
(repeated until power off/on :( )

Then I found these strings in UH0:/bin/sh (BFFS1.25)
block on free list clobbered
Tell root to fix this someday
Stopping myself...

What's up?
I grepped the 386BSD sources of /bin/sh, but no such strings. Where are the
sources from NetBSD-Amiga-/bin/sh ?
I assume that my system is installed correct (vmunix has found my 3 BSD-partitions).

Matthias

Here's my setup as shown by 'showconfig', I use bffs 1.25:

PROCESSOR:      CPU 68030/68882fpu/68030mmu
CUSTOM CHIPS:   ECS PAL Agnus (id=$0020), Normal Denise (id=$00ff)
VERS:   Kickstart version 37.175, Exec version 37.132, Disk version 38.35
RAM:    Node type $a, Attributes $205 (FAST), at $200000-$5fffff (4.0 meg)
		  Node type $a, Attributes $303 (CHIP), at $400-$fffff (~1.0 meg)
BOARDS:
 CBM A2630 68030/RAM card:   Prod=514/81($202/$51) (@$200000 4meg Mem)
 Board + ROM (HD?) (unidentified):   Prod=2017/11($7e1/$b) (@$e90000 64K)

------------------------------------------------------------------------------
Matthias Kirschnick                [email-masked]
Phone: 49 9131 85 8027
"Es geht auch anders, aber so geht es auch!" (Lotti Huber)

---

From: [email-masked] (Markus Wild)

> sources from NetBSD-Amiga-/bin/sh ?

I'm running bash as /bin/sh.

Only think I could imagine is that memory gets too close with 4M? Other
opinions? Weird...

-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH