Subject: Display problems with 644



I don't understand why, but this patch fixes the scrolling
region problem for me:

*** sys/arch/amiga/dev/ite.c-orig	Wed Sep  8 14:28:15 1993
--- sys/arch/amiga/dev/ite.c	Fri Oct  1 22:14:43 1993
***************
*** 1125,1131 ****
    ip->emul_level = EMUL_VT300_7;
    ip->eightbit_C1 = 0;
    ip->top_margin = 0; ip->bottom_margin = ip->rows - 1;
!   ip->inside_margins = 0;
    ip->linefeed_newline = 0;
    ip->auto_wrap = 0;
    ip->cursor_appmode = 0;
--- 1125,1131 ----
    ip->emul_level = EMUL_VT300_7;
    ip->eightbit_C1 = 0;
    ip->top_margin = 0; ip->bottom_margin = ip->rows - 1;
!   ip->inside_margins = 1;
    ip->linefeed_newline = 0;
    ip->auto_wrap = 0;
    ip->cursor_appmode = 0;

--
------------------------------------------------------------------------
Andy Heffernan                                            [email-masked]

---



> !   ip->inside_margins = 1;

Sorry to dissapoint you, but according to the manual for vt320 (that's
the only one I have, but it's official:-)) the default for inside_margins
is "off", not "on". If you have to set this to "on" most likely your
client software (vi?) is buggy, or your termcap entry, or both.

-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH

---



> client software (vi?) is buggy, or your termcap entry, or both.

	emacs
	IRC (reported by others)
	screen (reported by others)

	OK, then -- using my brilliant powers of deduction (i.e.,
taking a wild-assed guess), I conclude that the problem people are
having with scrolling regions is due to faulty termcaps.  I'm using the
termcap that was a result of doing a make in /usr/share/termcap from
the original usr.tgz file.  Was this updated for the new tar files?
Are you using something else?  Is your TERM set to something besides
vt200?

---



emacs
	   IRC (reported by others)

Hmmm, faulty termcap ? I have this problem with emacs (as reported
above). I customized the termcap (correctly, I think) and
did't succeed. The problem keeps existing :-(. My termcap
entry was like this:

vt200-ak|vt200 with 80 columns and 50 rows and amiga keys:li#50:
co#80:<keydefinitions>:tc=vt200:

Where keydefinitions include cursor keys etc.
The important entries are li and co. These are correct as
shown by stty -a: rows 50 cols 80. So: the bug seems to be
unfixable by custumization. Any ideas ?

------------------------------------------------------------------------------
Landi#2
[email-masked]
"The only time when I'm easy is when I'm killed by death"
"If You got the power, that don't mean You got the right"
                                                          I. Kilmister
------------------------------------------------------------------------------

---



> did't succeed. The problem keeps existing :-(. My termcap

Hm, I'm working with the termcap from /usr/gnu/lib/emacs/19.11/etc/termcap.dat.
Could you verify whether using that one instead makes a difference? I tried
using the official termcap, and didn't see any wrong behavior either...

> co#80:<keydefinitions>:tc=vt200:

Eh.. ak? The keyboard doesn't send the identical keys as amigados, mainly
to avoid troubles with 8bit-chopping applications. I.e. <CSI> is sent as
0x9b under amigados, and is sent as ^[[ under NetBSD. Try using *normal*
termcap entries please, no special amiga stuff. Being able to use standard
entries was my main goal when dropping the original hp-ite emulation...

> unfixable by custumization. Any ideas ?

the row/column values in the termcap entry don't have any meaning as long
as the used tty supports the TIOCGWINSZ ioctl.

-Markus