Subject: Correction in grf.c

From: [email-masked] (olivier lahaye)

The grf driver wasn't mappable due to a bug in the file:

	sys/arch/amiga/dev/grf.c

the following correction must be done:

just before the grfunmap() function (at the end of grfmap)

error=vm_mmap( ..... ) has wrong argument count.

the maxprot field is filled with VM_PROT_ALL, but the field prot is missed.

so the line becomes:

error = vm_mmap(&p->p_vmspace->vm_map,(vm_offset *)addrp,(vm_size_t)len,
		VM_PROT_ALL,
		VM_PROT_OT_ALL,  /* this field was forgotten */
		flags,
		(caddr_t)&vn,
		0);

so you've just have to insert VM_PROT_ALL, param.

====> THEN

in the function grfaddr(),

you must replace #if 0 by #if 1

and then you should be able to map the grf0 or grf1 driver memory :-)

------------------------------------------------------
now I'm searching about a bug in the ite key repeate routine.
if you press a key for a time (then it autorepeate itself)
Then without releasing the key, you hold another key.
This new key should repeate itself now.
Instead of this, the new key is printed once and the other key is
still repeating itself.
to stop, you must have the key up event.

this is an annoying problem, because when you have a sped typing you have
some strange typing.
for example : "cd /root" becomes "cdc c/root"
or "cdc ccc/root"

It seems that the problem is that the key down event is not detected
so current cahr issn't updated and no delay is activated.

so i'm still searching in sys/arch/amiga/dev/ite.c

I hope someone can help me ... 
-------------------------------------------------------

The last problem.

How can I switch the retina to graphic mode.
(the IOCTL isn't implemented)
and I'd like to write it.

-------------------------------------------------------

The notion of graphic mode is a good idea, but
when your font isn't appropriate to de video mode,
you cant get into trouble.

I suggest and intellingent graphic mode list
which would accomodate with the font behavyours.

-------------------------------------------------------

We've ported and XWindow libs and clients.
we're working on the server.
1st, we'll work for grf0 (custom chips)
but we're waiting for a retina solution.
the 1st stem (memory mapping) is solved.
the second is to adapt the keyboard and
the monochromes graphic routines.
(we'll have to implement an ioctl to activate/remove the hardware sprite)

(that would be an interresting feature if the hardware srite mouse
could be used for cut/paste operations in text mode)

-------------------------------------------------------

ANY COMMENT ARE WELLCOME.

---

From: [email-masked] (Markus Illenseer) "Correction in grf.c" (Oct 25, 7:36pm)

On Oct 25,  7:36pm, olivier lahaye wrote:
...]
> we're working on the server.

 nag ? :-) Could you please send me the amigabsd.cf, Imake.rules and
 Imake.tmpl (and any other amigabsd-related change)? I keep having 
 problems with the imake-tool, which generates Makefiles that have 
 spaces (yes, those things: ' ') in the pathnames (
 like: ln -s ../../ .. /lib/X/X.h .)

 I first thought it might be the cpp, but this one works fine i believe.

> 1st, we'll work for grf0 (custom chips)

 Yes, please. This one will be the 'standard' and the 'default' server
 anyway.

> (we'll have to implement an ioctl to activate/remove the hardware sprite)

 Remove the hardware-sprite anyway. And the screenblanker, too.

> could be used for cut/paste operations in text mode)

 Indeed. But how about using X11 for that ? :-)

-- 
Markus Illenseer

---

From: [email-masked] (Markus Wild)

> the maxprot field is filled with VM_PROT_ALL, but the field prot is missed.

Funny.. I fixed exactly this bug yesterday :-)

> and then you should be able to map the grf0 or grf1 driver memory :-)

Done, cool! One step further towards X ...

> to stop, you must have the key up event.

Interesting.. never tried this one :-)

> for example : "cd /root" becomes "cdc c/root"

Hm.. you got a weird typing attitude ;-) Nah, serious, I'd like to see
the bug fixed, but I'm on the war path with keyboard repeats anyway...

> so current cahr issn't updated and no delay is activated.

Nah, I think it sees the key down, and it checks whether it's alread
in repeat-mode. Sees it is, and doesn't start repeat again.. Pure guess,
without looking at sources though..

> and I'd like to write it.

Oh.. do you have the NCR manual for the chip? I'm still hoping that
Lutz Vieweg finds a little timeslot to add the missing ioctl. He already
did the major part of the existing driver, and I think he'd be best
suited for this task :-)

> which would accomodate with the font behavyours.

Hm, due to bus-congestion in alphanumeric mode, the Retina can't go
much beyond 800x600, and in that resolution, I can still read the 8x8
font quite well. In gfx-mode, we're running custom fonts anyway, so
where is the problem?

> the monochromes graphic routines.

I'm currently writing a /dev/kbd and /dev/mouse, if you assume the
SunOS interface to those, you'll be happy :-)

> (we'll have to implement an ioctl to activate/remove the hardware sprite)

Yep, and to position it. Btw, the Retina includes a hardware sprite
as well in gfx-mode, that's the main reason I want hi-level mouse support.

> could be used for cut/paste operations in text mode)

That was the original intention of Mike Schwartz when he wrote the 
cc-console, I think..

-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH