Subject: updating /vmunix

From: Nick Borko <[email-masked]>

What is the easiest way to update /vmunix on NetBSD?  Barring network access,
of course.

Nick

---

From: [email-masked] (olivier lahaye)

>What is the easiest way to update /vmunix on NetBSD?  Barring network access,

I use BFFSFileSystem on the amiga side,
when I want to boot BSD, I just have to:

copy BSD_ROOT:vmunix RAM:   /* due to a bug of open() in gcc libamy */
loadbsd ram:vmunix.

this way I allways have a updated vmunix.

                [email-masked]

---

From: [email-masked] (Markus Illenseer) "Re: updating /vmunix" (Oct 27, 9:34am)

On Oct 27,  9:34am, olivier lahaye wrote:
> Subject: Re: updating /vmunix
> 

 Yes, but i believe he wanted to update /vmunix, not RAM:vmunix :-)

 Unless you devellop/compile the kernel yourself, you must update /vmunix
 in order to have a running vmstat and such. 

 What you can do is the (slightly dangerouse) filetodev-trick.
 Copy a vmunix.tar (tar !) with filetodev to the swap-partition under AmigaDOS.

 Then boot NetBSD into single-user mode.
 First thing you do by then is: tar xvf /dev/rsdxb
 Whereas x is your SCSI-device.

 That's the way i do it :-)

-- 
Markus Illenseer