Subject: Re: daily CVS update output

From: [email-masked] (Ty Sarna)

Seen in current-users:

In article <[email-masked]> Charlie Root <[email-masked]> writes:
> Subject: sun-lamp CVS update output
> 
> Updating src and othersrc trees:
> 
[...]
> U src/sys/arch/amiga/conf/ROUS

Yow! That's my config file. I don't mind it being included, but I dunno
as it's really useful to anyone else. Was including it intentional?

If you do want it, at least let me give you an up-to-date version...

-- 
Ty Sarna                 "As you know, Joel, children have always looked
[email-masked]        up to cowboys as role models. And vice versa."

---

From: [email-masked]

> If you do want it, at least let me give you an up-to-date version...

Go ahead:-) Yup, I think it's a good idea to have some sample config
files in the tree.

-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH

---

From: [email-masked] (Michael L. Hitch)

> Go ahead:-) Yup, I think it's a good idea to have some sample config

  Perhaps some of the sample config files should include some comments
about what the sample config file is doing differently than the AMIGA
file.  In my case, the ZEUS config file is my normal config file which
I created to support both the Zeus SCSI adapter and the 33C93 adapters
(specifically the GVP in my case).  Since that support is now included
in the AMIGA config file, the ZEUS file stays pretty close to AMIGA.  The
ZEUSONLY was another example of configuring a kernel that only included
support for the ZEUS SCSI adapter.  This isn't needed anymore since the
rz/tz stuff is now obsolete and not used.

Michael

-- 
Michael L. Hitch			INTERNET:  [email-masked]
Computer Consultant			BITNET:  [email-masked]
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA

---

From: [email-masked] (Ty Sarna)

> Go ahead:-) Yup, I think it's a good idea to have some sample config

Here's an update dversion of mine, then. Not very exciting, though --
mainly just the recent GENERIC version, with stuff I don't need removed.

#
# ROUS -- rous.endicor.com
#
# A3000T 2C/8F, A2065, A2024
#

machine		"amiga"
#cpu		"M68020"
cpu		"M68030"
#cpu		"M68040"

ident		ROUS

#
# Add support for about 16 users. This variable is used to size
# various kernel structures.
#
maxusers	16

#
# Set the timezone offset that the kernel will use.
#
timezone	6 dst	# US/Central

#
# Set the maximum number of file descriptors
#
maxfdescs	2048

#
# The following adds additional floating-point capabilities to 
# the MC68040.  A subset of the MC6888x instruction set is 
# executed by the MC68040 on-chip FPU.  The remaining 
# floating-point instructions are emulated in software.
#
#options	FPSP		# MC68040 floating point support

options		FPCOPROC	# Support for MC68881/MC68882 (mandatory)

#
# Networking options
#
options		INET		# Basic networking support (mandatory)
#options	GATEWAY		# packet forwarding for gateways
#options	MULTICAST	# multicast IP
#options	MROUTING	# multicast routing
#options	ISO		# ISO Networking support
#options	TPIP		# ARGO TP networking support
#options	CCITT		# CCITT X.25
#options	NS		# Xerox XNS

#
# File system related options
#
#options	QUOTA		# Disk quotas for local disks
options		NFSSERVER	# NFS server side code
options		NFSCLIENT	# NFS client side code
#
# Support for various types of filesystems
#
options		MFS		# Memory based filesystem
options		PROCFS		# Process filesystem
options		KERNFS		# Kernel parameter filesystem
#options	MSDOSFS		# DOS filesystem
options		FDESC		# /dev/fd filesystem
options		LOFS		# Loopback filesystem
options		ISOFS		# CD ROM support
options		PORTAL		# Portal filesystem

options		FIFO		# FIFO operations on vnodes

# pager options
options		SWAPPAGER	# Pager for swap device
options		VNODEPAGER	# Pager for vnodes
options		DEVPAGER	# Pager
#options	BANKEDDEVPAGER	# Retiname bank pager

#
# Compatability options for various existing systems
#
options		COMPAT_SUNOS	# Support to run Sun-2/3 executables
#options	HPUXCOMPAT	# HP300 HPUX compatability
options		"COMPAT_43"	# 4.3 BSD compatible system calls
options		"TCP_COMPAT_42"	# Use 4.2 BSD style TCP
options		"COMPAT_NOMID"	# ???

#
# Support for System V IPC facilities.
#
options		SYSVSHM		# System V shared memory
options		SYSVMSG		# System V messages
options		SYSVSEM		# System V semaphores

#
# Graphics options
# 
options		GRF_ECS			# Enhanced Chip Set
options		GRF_NTSC		# NTSC
options		GRF_PAL			# PAL
options		"GRF_A2024"		# Support for the A2024
options		ITE_AUTOWRAP		# turn ite autowrap on by default

#
# Support for various kernel options
#
options		LKM			# Loadable Kernel Modules
options		KTRACE			# Add kernel tracing system call
options		"PANICWAIT"		# Require keystroke to dump/reboot
options		DIAGNOSTIC		# Add additional error checking code
#options	DEBUG			# Add debugging statements
#options	PANICBUTTON		# Forced crash via keypress (???)
options		"NKMEMCLUSTERS=256"	# Size of kernel malloc area
#options	GENERIC			# Mini-root boot support
#options	PROFTIMER		# Kernel profiling support
#options	PRF_INTERVAL=500"	# Clock ticks between profile interrupts
#options	KGDB			# Kernel debugger (KGDB) support
options		"PPP_OUTQ_SIZE=4096"	# Size of large PPP output queue

#
# Kernel name and root/swap parameters
#
#config		netbsd swap generic
config		netbsd root on sd0a swap on sd0b

#pseudo-device	sl	1	# Serial Line interface
#pseudo-device	ppp	1	# Point-to-Point Protocol (PPP)
pseudo-device	bpfilter 16	# Berkeley packet filter
pseudo-device	ite	2	# Bit-mapped display terminal emulator
pseudo-device	view	10	# View (graphics mapping)
pseudo-device	kbd	1	# Keyboard support
pseudo-device	mouse	2	# Mouse support
pseudo-device	aconf		# AUTOCONFIG(TM) info device driver
pseudo-device	pty		# Pseudo-tty support
pseudo-device	loop		# Loopback network (mandatory)
pseudo-device	ether		# Ethernet support
pseudo-device	vn	10	# Vnode disk driver

#
# The following sections describe various hardware options.
#

#
# Devices on an Amiga 3000
#
master		a3000scsi0	at manufacturer	1	product	1
disk		sd0	at a3000scsi0 slave 0
disk		sd1	at a3000scsi0 slave 1
disk		sd2	at a3000scsi0 slave 2
disk		sd3	at a3000scsi0 slave 3
disk		sd4	at a3000scsi0 slave 4
disk		sd5	at a3000scsi0 slave 5
disk		sd6	at a3000scsi0 slave 6
tape		st0	at a3000scsi0 slave ?
tape		st1	at a3000scsi0 slave ?

#
# Devices on an A2091
#
#master		a2091scsi0	at manufacturer 514	product 3
#disk		sd0	at a2091scsi0 slave 0
#disk		sd1	at a2091scsi0 slave 1
#disk		sd2	at a2091scsi0 slave 2
#disk		sd3	at a2091scsi0 slave 3
#disk		sd4	at a2091scsi0 slave 4
#disk		sd5	at a2091scsi0 slave 5
#disk		sd6	at a2091scsi0 slave 6
#tape		st0	at a2091scsi0 slave ?
#tape		st1	at a2091scsi0 slave ?

#
# Devices on an GVP Series II
#
#master		gvp11scsi0	at manufacturer 2017	product 11
#disk		sd0	at gvp11scsi0 slave 0
#disk		sd1	at gvp11scsi0 slave 1
#disk		sd2	at gvp11scsi0 slave 2
#disk		sd3	at gvp11scsi0 slave 3
#disk		sd4	at gvp11scsi0 slave 4
#disk		sd5	at gvp11scsi0 slave 5
#disk		sd6	at gvp11scsi0 slave 6
#tape		st0	at gvp11scsi0 slave ?
#tape		st1	at gvp11scsi0 slave ?

#
# Devices on an PPI Zeus SCSI
#
#master		zeusscsi0	at manufacturer	2026	product	150
#disk		sd0	at zeusscsi0 slave 0
#disk		sd1	at zeusscsi0 slave 1
#disk		sd2	at zeusscsi0 slave 2
#disk		sd3	at zeusscsi0 slave 3
#disk		sd4	at zeusscsi0 slave 4
#disk		sd5	at zeusscsi0 slave 5
#disk		sd6	at zeusscsi0 slave 6
#tape		st0	at zeusscsi0 slave ?
#tape		st1	at zeusscsi0 slave ?

#
# Devices on an CSA Magnum SCSI
#
#master		magnumscsi0	at manufacturer	1058	product	17
#disk		sd0	at magnumscsi0 slave 0
#disk		sd1	at magnumscsi0 slave 1
#disk		sd2	at magnumscsi0 slave 2
#disk		sd3	at magnumscsi0 slave 3
#disk		sd4	at magnumscsi0 slave 4
#disk		sd5	at magnumscsi0 slave 5
#disk		sd6	at magnumscsi0 slave 6
#tape		st0	at magnumscsi0 slave ?
#tape		st1	at magnumscsi0 slave ?

#
# Common hardware
#

#
# Serial port interface
#
device		ser0	at manufacturer	1	product	3

#
# Parallel port interface
#
device		par0	at manufacturer	1	product	6

#
# Floppy drive support (sigh)
#
#master		floppy0	at manufacturer	1	product	2

#
# Graphics routines for the AMIGA native custom chip set
#
device		grf0	at manufacturer	1	product	7
#device		grf1	at manufacturer	18260	product	6	# Retina

#
# A2410
#
#device		tiga0	at manufacturer 1030	product 0

#
# builtin clock (should all identify as "rtclock")
#
device		rtclocka0 at manufacturer 1	product 4 # A3000/A4000
device		rtclockb0 at manufacturer 1	product 9 # A2000

#
# ethernet board (AMD 7990 LANCE controller, A2065 or Ameristar)
#
device		le0	at manufacturer ?	product ?