Subject: This week's NetBSD/amiga changes

From: Operator <[email-masked]>

Below is a summary of changes that were committed in the last week.
This is an automated message. Please send any comments to
[email-masked]

[note: this is the first post from this service, and there were a few
problems getting it set up right. Plus, I had /var fill up, causing some
messages to get dropped on the floor, and then the machine was down for
a bit and missed the cron job, so I had to run the weekly program
manually... I hope it'll work a little better next week :->  --Ty]

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev/grf
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev/grf

Removed Files:
	grf_bitmap.h grf_colormap.h grf_draw.h grf_mode.c grf_mode.h 
	grf_monitor.c grf_monitor.h grf_types.h grf_view.c grf_view.h 
	grfcc.c 
Log Message:
relocated to dev/grfabs{.c,_reg.h} files.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev/grf/grf_cc
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev/grf/grf_cc

Removed Files:
	grf_cc_a2024_mode.c grf_cc_custom.h grf_cc_global.c 
	grf_cc_h_mode.c grf_cc_hdl_mode.c grf_cc_hl_mode.c 
	grf_cc_mode.c grf_cc_pal_a2024_mode.c grf_cc_ph_mode.c 
	grf_cc_phdl_mode.c grf_cc_phl_mode.c grf_cc_priv.h 
	grf_cc_view.c grf_ccc.c 
Log Message:
relocated into dev/grfabs_cc{.c,glb.c,reg.h} files.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/conf
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/conf

Modified Files:
	Makefile.amiga files.amiga 
Log Message:
chnaged to handle new (and removed) files.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev

Modified Files:
	a2091dma.c a3000dma.c event.c grf.c grf_cc.c grf_rt.c grf_tg.c 
	gvp11dma.c if_le.c ite.c ite_cc.c ite_rt.c kbd.c kbdmap.c ms.c 
	par.c rtclocka.c rtclockb.c scsi.c scsidefs.h sd.c ser.c 
	siop.c st.c view.c viewioctl.h 
Added Files:
	grfabs.c grfabs_cc.c grfabs_ccglb.c grfabs_ccreg.h 
	grfabs_reg.h 
Log Message:
cleaned up include's relocated grf/* stuf to grfabs*.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/doc
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/doc

Added Files:
	CHANGES 
Removed Files:
	README.CHOPPS-CONSOLE README.CHOPPS-CONSOLE2 
Log Message:
added local CHANGES file for things that would not interest
NetBSD in general.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/sys
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/sys

Modified Files:
	disklabel.h 
Log Message:
Changed amiga MAXPARTITIONS to 16.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/amiga
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/amiga

Modified Files:
	Locore.c amiga_init.c autoconf.c cc.c cc.h cia.c clock.c 
	cons.c disksubr.c dkbad.c dlists.c genassym.c locore.s 
	machdep.c mem.c pmap.c swapgeneric.c sys_machdep.c trap.c 
	vm_machdep.c 
Removed Files:
	cc_2024.c cc_2024.h cc_audio.c cc_audio.h cc_blitter.c 
	cc_blitter.h cc_chipmem.c cc_chipmem.h cc_copper.c cc_copper.h 
	cc_types.h cc_vbl.c cc_vbl.h pte.h 
Log Message:
merged most cc_* (all but one) into cc.c and cc.h, cleaned up include.
removed local pte.h use machine/pte.h

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/lib/libkvm
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/lib/libkvm

Modified Files:
	Makefile kvm.c 
Log Message:
temporary additional lookup of cpu040 for amiga's until new kvm stuff or new
amiga 040 VM stuff.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev

Modified Files:
	st.c 
Log Message:
moved n "}" outside of conditional DEBUG

---------------------------------
From: "Chris G. Demetriou" <[email-masked]>

Update of /b/source/CVS/src/sbin/reboot
In directory sun-lamp.cs.berkeley.edu:/usr/src/sbin/reboot

Modified Files:
	reboot_amiga.8 reboot_hp300.8 reboot_i386.8 reboot_mac68k.8 
	reboot_sparc.8 
Log Message:
U* to NetBSD, as appropriate

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/conf
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/conf

Modified Files:
	Makefile.amiga files.amiga 
Log Message:
modified to use generic cons.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/doc
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/doc

Modified Files:
	CHANGES 
Log Message:
latest changes indicated.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/include
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/include

Modified Files:
	vmparam.h 
Log Message:
amiga now has USRSTACK at 0x0e000000 for further sun compat.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/amiga
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/amiga

Modified Files:
	color.h conf.c 
Added Files:
	kdassert.h 
Removed Files:
	cons.c cons.h 
Log Message:
modified to use generic cons, added kernel assert macro.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev

Modified Files:
	grf.c grf_rt.c grfabs_ccglb.c ite.c ite_cc.c ite_rt.c ite_tg.c 
	itevar.h kbd.c ser.c view.c 
Log Message:
modified to use generic cons. (and some grf defs changed)

---------------------------------
From: [email-masked] (Theo Deraadt)

> amiga now has USRSTACK at 0x0e000000 for further sun compat.

I don't get why this is needed. Please explain.

---------------------------------
From: [email-masked] (Chris Hopps)

> 
> > amiga now has USRSTACK at 0x0e000000 for further sun compat.
> 
> I don't get why this is needed. Please explain.

Ask Markus its his change, I didn't argue about it much becuase for
the most part it is cosmetic.

Chris.

---------------------------------
From: "Christian E. Hopps" <[email-masked]>

Update of /b/source/CVS/src/sys/arch/amiga/dev
In directory sun-lamp.cs.berkeley.edu:/f/users/chopps/src/sys/arch/amiga/dev

Modified Files:
	sd.c 
Log Message:
fix typo.

---------------------------------

---

From: [email-masked] (Markus Illenseer) "This week's NetBSD/amiga changes" (Feb 19, 1:31pm)

On Feb 19,  1:31pm, Operator wrote:
> Subject: This week's NetBSD/amiga changes

[...]

Do i understand it correctly that the most up-to-date kernel sources
can be found on sun-lamp then? All Amiga-specific changes incorporated/added?

-- 
Markus Illenseer