Subject: Looking for new kernel

From: "Stephen J. Roznowski" <[email-masked]>

I'm trying to build a new kernel from the 19 Feb sun-lamp sources.

It compiles "correctly", but when I do a "cp vmunix /dev/reload",
all I get is a grey screen. I'm using the loadbsd-current from
eunet. [This is with the 19 Feb version of everything; cc, ld, sh, ...]

Can someone point me in a direction for where I can look for the
problem, or better yet, upload a new "generic" kernel to eunet?
[I know that at least Chris Hopps is working on this....]

Thanks,
-SR

---

From: [email-masked] (Chris Hopps)

> eunet. [This is with the 19 Feb version of everything; cc, ld, sh, ...]

I compiled you A3000 and also cannot cp vmunix /dev/reload.  However I
am able to boot this kernel if I loadbsd it.

> [I know that at least Chris Hopps is working on this....]

Yes I looked at the (significant amount BTW) of options that I had
compared with yours since my /dev/reload works.  Here is the list of
options I have and you don't (in A3000) the list is sorted in the
order in which I think problems may arise, i.e. the first one is most
suspect:

DEBUG 
PANICWAIT
NFS
NFSSERVER
NFSCLIENT
ISOFS
FDESC
PORTAL
BANKDEVPAGER
GRF
GRF_OCS
GRF_PAL
GRF_A2024
GRF_CUSTOM_CHIP_MODES (I don't know if I ever used this)
HAVE_USL_UFS (I am gonna grep this to see if its even neeeded)
LKM (I know this isn't it, becuase I just added it)

Note though that I use the old ld to link my kernels and am unaware if
the new one works. (kernel-ld on my system is ld.old from the last bin dist)

Chris.

---

From: Bob Slawson <[email-masked]>

> From: [email-masked] (Chris Hopps)
> Date: Sun, 20 Feb 1994 19:54:12 -0500 (EST)

> the new one works. (kernel-ld on my system is ld.old from the last bin dist)

loadbsd rejects any kernel I've built with a recent link editor
(with  LD=ld -Bstatic  in the Makefile). I noticed that

`file netbsd' linked with `ld -Bstatic -n ....' returns
(this is from memory)

	NetBSD/m68k pure executable binary

whereas when linked with ld.old from the 720 usr.bin

	old sun-2 pure executable binary

`file vmunix.744' also returns "old sun-2 ..."

Is there a deep reason why this anachronism is necessary?  Are there
differences other than the magic numbers?  I think it would be
convenient to be able to use a current link editor when building
kernels rather than keeping a single purpose one around.

Robert W. Slawson
Dept. of Astronomy,
Univ. of Western Ontario,			Astronomy is looking up...
London, Ontario  N6A 3K7
CANADA

---

From: [email-masked] (Michael L. Hitch)

> kernels rather than keeping a single purpose one around.

  The kernel is not a demand-paged executable, which is what the
standard 'ld' will generate.  The first page of a demand-paged
executable is linked to address 0x2000.  The kernel has to be linked so
that the first byte of the code segment is linked at 0.  Loadbsd and the
/dev/reload magic expect this, so you need the ld.old to create the
kernel executable.

Michael

-- 
Michael L. Hitch			INTERNET:  [email-masked]
Computer Consultant			BITNET:  [email-masked]
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA

---

From: [email-masked] (Chris Hopps)

> /dev/reload magic expect this, so you need the ld.old to create the

Of course -n which we always had requests an NMAGIC file, however the
new ld was still linking at 0x2000... -T 0 took care of that. :^)

Chris.