Subject: ppp to sun crashes

From: Markus Landgraf <[email-masked]>

Hi NetBSDers,
I try to run a ppp link to a Sparc Cassic under Solaris 2.3. On the
Sparc side we use the ppp which is included in Solaris aspppd/aspppls.
All works well until the two ppp-daemons get in contact, at this
moment the sparc reboots. I have tested this with the following
procedure:

- First aspppd was stared automatically on the sparc
- then I logged logged in via kermit from the NetBSD side
- then I started the aspppls manually on the sparc
- when wiered characters appear on the screen ( I think these are ppp
configuration requests etc), I stop kermit and start the pppd on
NetBSD.

Until this moment all was as expected ( and documented). But in the
moment the NetBSD pppd is started the Sparc dies.

Can someone help me ? 
Is it a wrong config or just a Solaris bug ?
Is it possible that NetBSD pppd produces invalid requests ?

Thank you in advance for any help

------------------------------------------------------------------------------
Landi#2
[email-masked]
"The only time when I'm easy is when I'm killed by death"
"If You got the power, that don't mean You got the right"
                                                          I. Kilmister
------------------------------------------------------------------------------

---

From: [email-masked]

Solaris 2.3 has a bug in its PPP code.  Sun has released a patch - talk to
your sun rep or (if you _really_ have no alternative) I can look up the
patch number.  I'd be more helpfull, but I'm swamped with work right now...

--
Carson Gaspar -- [email-masked], [email-masked]
<This is the boring business .sig - no outre sayings here>

---

From: [email-masked] (Francis Demierre)

> Date: Mon, 7 Feb 1994 13:23:54 +0500
   > Message-Id: <9402071823.AA09094@taltos.>
   > From: [email-masked]
   > To: Markus Landgraf <[email-masked]>
   > Cc: [email-masked]
   > Subject: Re: ppp to sun crashes
   > In-Reply-To: <9402071747.AA15483@crunch>
   > References: <9402071747.AA15483@crunch>
   > Reply-To: [email-masked]
   > Content-Length: 350
   > Sender: [email-masked]
   > Status: RO
   > 
   > 

This might be the Patch ID (that is the only one about PPP for SunOS5.3
according to official patch list dated Sat Feb  5 22:16:43 MET 1994.

Patch-ID# 101425-01
Keywords: negotiation address LCP packets ACKed
Synopsis: SunOS 5.3: ppp violates standard for LCP packets.
Date: Dec/13/93
Solaris Release: 2.3
SunOS release: 5.3

Topic: SunOS 5.3:ppp violates standard for LCP packets, interoperability problems
BugId's fixed with this patch: 1145413 1150836
Relevant Architectures: sparc

Francis

---

From: Markus Landgraf <[email-masked]>

>>>>> "mw" == mw  <[email-masked]> writes:

    >> I try to run a ppp link to a Sparc Cassic under Solaris 2.3. On
    mw> Did you apply sun-patch 101425-01? This is from its README:
    mw> Patch-ID# 101425-01 Keywords: negotiation address LCP packets
    mw> ACKed Synopsis: SunOS 5.3: ppp violates standard for LCP
    mw> packets.  Date: Dec/13/93
 
    mw> Solaris Release: 2.3
 
    mw> SunOS release: 5.3
 
    mw> Unbundled Product:
 
    mw> Unbundled Release:
 
    mw> Topic: SunOS 5.3:ppp violates standard for LCP packets,
    mw> interoperability problem s

No, I didn't and I think this was the problem. I will test it at this
weekend. My brother got the same information from the Sun Newsgroup.

---

From: Markus Landgraf <[email-masked]>

mw> Solaris Release: 2.3
 
    mw> SunOS release: 5.3
 
    mw> Unbundled Product:
 
    mw> Unbundled Release:

---

From: [email-masked]

> I try to run a ppp link to a Sparc Cassic under Solaris 2.3. On the

Did you apply sun-patch 101425-01? This is from its README:
Patch-ID# 101425-01
Keywords: negotiation address LCP packets ACKed
Synopsis: SunOS 5.3: ppp violates standard for LCP packets.
Date: Dec/13/93
 
Solaris Release: 2.3
 
SunOS release: 5.3
 
Unbundled Product:
 
Unbundled Release:
 
Topic: SunOS 5.3:ppp violates standard for LCP packets, interoperability problem
s

Ciao,
-Markus
-- 
CHUUG/EUnet Switzerland				Markus Wild
Zweierstrasse 35	Tel: +41 1 291 45 80	[email-masked]
CH-8004 Zuerich		Fax: +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH