Subject: Re: kernel compile problems <[email-masked]>

From: bryan collins <[email-masked]>

> 
>    cpp -DLOCORE -I. -I../../../../arch -I../../../.. -I../../../../sys -DSPHI
NX -DI
>    486_CPU -DUCONSOLE -DXSERVER -DTCP_COMPAT_42 -DCOMPAT_43 -DCOMPAT_09 -DCOM
PAT_NO
>    MID -DUSER_LDT -DINET -DKERNFS -DFDESC -DMSDOSFS -DCD9660 -DMROUTING -DMUL
TICAST
>     -DNFSCLIENT -DNFSSERVER -DMFS -DQUOTA -DFFS -DFIFO -DKTRACE -DDEVPAGER -D
VNODEP
>    AGER -DSWAPPAGER -DMACHINE_NONCONTIG -DKERNEL -Di386 ../../i386/locore.s |
 as  -
>    o locore.o
>    sh: warning: running as root with dot in PATH
>    ../../i386/locore.s:144: unterminated character constant
>    ../../i386/locore.s:487: unterminated character constant
>    ../../i386/locore.s:566: unterminated character constant
> 
> This could only happen if you're using a different `cpp' or `as' than
> the ones supplied in NetBSD.
> 

I'm using binaries compiled from the sept 12th source.

102 ~ > file `which cpp`
/usr/libexec/cpp: NetBSD/i386 demand paged dynamically linked executable
103 ~ > file `which as`
/usr/bin/as: NetBSD/i386 demand paged dynamically linked executable

bry
---
 Bryan Collins
 Coombs Computing Unit
 Australian National University
 Canberra, Australia, 0200
 Tel: (06) 249 3102
 Email: [email-masked]

---

From: Jan-Hinrich Fessel <[email-masked]>

In message <[email-masked]>you write:
->   o locore.o
->   sh: warning: running as root with dot in PATH
->   ../../i386/locore.s:144: unterminated character constant
->   ../../i386/locore.s:487: unterminated character constant
->   ../../i386/locore.s:566: unterminated character constant
->
->This could only happen if you're using a different `cpp' or `as' than
->the ones supplied in NetBSD.

Wrong ;-(
It happended to me with standard gcc/cpp/as on some other location,
if I remember right, it was during libc build.  I simply typed make
again, and this time it worked.
No, no errors reported anywhere else.

Gruesse
       Oskar

 ==============================================================================
 					Tragbar ist, was nicht herunterfaellt.
						    [email-masked]
 ==============================================================================