Subject: Re: ethernet problems

From: [email-masked] (Markus Illenseer) "Re: ethernet problems" (Sep 6, 3:55pm)

On Sep 6,  3:55pm, David Jones wrote:
> Subject: Re: ethernet problems
> >  /etc/resolv.conf is empty
> 
> Empty, or non-existent?

 No matter. Normally non-existent.

> >  /etc/hostname.le0:
> >  inet 233.100.1.1 255.255.255.0
> 
> Isn't this a class-D address, reserved for multicast?

 255.255.255.0 is for netmask i thought.

 233.100.1.1 is a fictive address for my very own network. Could be 
altered to anything else of course.

 Can anyone provide a _valid_ hostname.le0 entry please?

> >  BTW, what are the devices tun0 and eon0 for?
> 
> tun0 is a "tunnel device" used somehow for tunneling network protocols through
> other protocols.  If someone can point me to the source code, I can look
> at eon0.

 The GENERIC kernel i use has both configured. I can even access eon0 - but
what is it? .-)

 I feel desperate :-/
 Any ideas how to debug this problem? netstat is no big help.

-- 
Markus Illenseer

---

From: David Jones <[email-masked]>

>  inet 233.100.1.1 255.255.255.0

Yup - just checked Comer's book.

This is a multicast address.

Over Ethernet, there is a direct translation between multicast IP and the MAC
address.  For regular addresses, ARP is used to get a dynamic translation.

So, your machine ain't ARPing anything, and hence can't talk.

-- 
David Jones, M.A.Sc student, Electronics Group (VLSI), University of Toronto
           email: [email-masked], finger for PGP public key
        finger [email-masked] for latest Toronto Free-Net information
          <A HREF="http://www.eecg.toronto.edu/~dej">Click me!</A>

---

From: David Jones <[email-masked]>

Empty, or non-existent?

>  ifconfig le0 shows:
>  le0: flags=843<UP,BROADCAST,RUNNING,SIMPLEX>
>          inet 233.100.1.1 netmask 0xffffff00 broadcast 233.100.1.255
>  lo0: flags=8009<UP,LOOPBACK,MULITCAST>
>          inet 127.0.0.1 netmask 0xff000000
> 
>  netstat -ra:
> Internet:
> Destination       Gateway          Flags    Refs     Use    Interface
> localhost         localhost        UH         2      24     lo0
> 233.100.1         link#1           UC         0       0     le0
> tiger             localhost        UGHS       0      65     lo0
> 
> What is that SIMPLEX output in ifconfig for? Never seen before.
> What is that link#1 output in netstat -ra? Never seen before.

I've seen SIMPLEX.  I think that means the interface is not in promiscuous
mode, but unsure.  The link#1 may be due to your choice of multicast address.
Again unsure.