Subject: Hard disk recognition ?

From: Bill Haygood <[email-masked]>

I obtained Amiga pre-release2 Sep 25th from NetBSD.org and received
the following output when I executed "loadbsd -b netbsd":

--------------------------------------------------------------------------
Askboot...Using 32M FASTMEM at 0x80000000, 2M CHIPMEM

Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.

NetBSD 1.0_BETA (INSTALL) #0: Fri Sep  2 12:25:09 EDT 1994
    [email-masked]:/local/src/sys/arch/amiga/compile/INSTALL
Amiga 500/2000 (m68040 CPU/MMU/FPU)
real  mem = 33554432 (4096 pages)
avail mem = 30375936 (3708 pages)
using 217 buffers containing 1777664 bytes of memory
memory segment 0 at 08000000 size 02000000
memory segment 1 at 00000000 size 00200000
mainbus0 (root)
clock0 at mainbus0: system hz 100 hardware hx 715909
ser0 at mainbus0: input fifo 512 output fifo 32
par0 at mainbus0
kbd0 at mainbus0
grfcc0 at mainbus0
grf0 at grfcc0: width 640 height 400 colors 4
ite0 at grf0: rows 50 cols 79 repeat at (30/100)s next at (10/100)s
                                                           has keyboard
fdc0 at mainbus0:dmabuf pa 0x1e3030
fd0 at fdc0: 3.5dd 80 cyl, 2 head, 11 sec [9 sec], 512 bytes/sec
 not configured
ztwobus0 at mainbus0
mgnsc0 at ztwobus0 rom 0xc3900000 man/pro 1058/17
mgnsc0: siop id 7 reset
scsibus7 at mgnsc0
siopchkintr: target 0 ds 555828
scripts 809de64 ds 830b828 regs ed0000 dsp 0 dcmd 0
siopchkintr:  istat ff dstat 0 sstat0 0 dsps 0 dsa - sbcl 0 sts ff msg ff
mgnsc0: siop id 7 reset
    [above 4 lines repeated another 15 times occasionally with
                                 slightly different parameter values]
root device> fd0
2 mice configured        [I have only 1 mouse]
10 views configured
WARNING: no swap space found
Sep 26 08:55:50 init: /etc/spwd.db: No such file or directory
Enter pathname of shell or RETURN for sh:
erase ^?, werase ^W, kill ^U, intr ^C

Welcome to the NetBSD 1.0 installation program.

This program is designed to help you put NetBSD on your hard disk,
in a simple and rational way.  Its main objective is to format,
mount and create an fstab for your root (/) and user (/usr)
partitions.

As with anything which modifies your hard drive's contents, this
program can cause SIGNIFICANT data loss, and you are advised
to make sure your hard drive is backup up before beginning the
installation process.

Default answers are displayed in brackets after the questions.
You can hit Control-C at any time to quit, but if you do so at a
prompt, you may have to hit return.  Also, quitting in the middle of
installation may leave your system in an inconsistent state.

Proceed with installation? [n] yesiopchkintr: target 7 ds 555828
scripts 809de64 ds 830b828 regs ed0000 dsp 0 dcmd 0
siopchkintr: istatt ff dstat 0 sstat0 0 dsps 800 dsa 0 sbcl 0 sts ff msg ff
mgnsc0: siop id 7 reset
panic: siop_scsidone
Stopped at       0x6d2c0:         unlk    a6
db> s

----------------End of NetBSD video display output------------------------

I made the install floppies IAW instructions (using "rawwrite" to
write file "inst-10.fs" onto a floppy.

My hardware configuration:
   Amiga B2000 box with CSA 40/4 Magnum 68040 accelerator/disk controller
   Micropolis 1.7 GB hard disk (Unix partitions in last 556 MB)
   32 MB of 32-bit FASTMEM and 2 MB of CHIPMEM
   Nexus disk controller with SyQuest 88 MB removable and DAT backup
              tape drive attached

I recorded the above output on my VCR (a few items I found hard to
read, but I feel confident I got most of the output correctly).  I 
would guess that I have a hard disk recognition problem, and I have 
used hdtoolbox and verified the settings at least six times.  I 
welcome any advice as to what I might do to fix the problem.

 _
|_)
|_)ill

---

From: William J Coldwell <[email-masked]>

>mgnsc0 at ztwobus0 rom 0xc3900000 man/pro 1058/17
                        ^^^^^^^^^^-- Micheal: What's this?
>                                 slightly different parameter values]

Well, looks like you're the 1st person with a Magnum to run NetBSD/Amiga.   
When I gave Michael the code to get the Magnum up and running, I no longer  
had one to be able to actually test the code on.  You're the guinea pig ;-).

>Stopped at       0x6d2c0:         unlk    a6

I would think that the C710 is not being configured correctly.

>   Nexus disk controller with SyQuest 88 MB removable and DAT backup

I thought I gave the Nexus information to Michael, but I guess I didn't.   
This will probably make it into Release 1.1 :-(

--
 William J. Coldwell - [email-masked] - Cryogenic Software

---

From: [email-masked] (Michael L. Hitch)

>                         ^^^^^^^^^^-- Micheal: What's this?
  I would guess that it's an error in copying the data from the

> >scripts 809de64 ds 830b828 regs ed0000 dsp 0 dcmd 0
                                   ^^^^^^
  This is what should be displayed when the board is configured and looks
reasonable, although I'm curious what is configured at 0xe90000, 0xea0000,
0xeb0000, and 0xec0000.  My Zeus SCSI is configured first (since the
coprocessor board is configured before the Zorro II bus boards) and is
at 0xe90000.

  [Oops, I see what happened here.  The board is probably at 0xe90000,
which is what I would expect.  Instead of adding the offset 0x8000 to
the base address, the driver is adding 0x40000.  It looks like I missed
changing that offset when I used the WarpEngine file as the base for
the Magnum driver.]

> had one to be able to actually test the code on.  You're the guinea pig ;-).

  Didn't you get the very first driver to work?  I thought I remember you
trying it out.  I know that there wasn't anyone to test the Magnum driver
after it was rewritten for the new configuration process.

> This will probably make it into Release 1.1 :-(

  Nope, I never got it, so I didn't write the driver support for it.

Michael

-- 
Michael L. Hitch			INTERNET:  [email-masked]
Computer Consultant
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA