Subject: ethernet problems

From: [email-masked] (Markus Illenseer)

I still have some annoying problems with ethernet where i want
your advice.

 (All works fine under ADOS using AmiTCP, so no hardware problem)

 Kernel is most recent GENERIC from ftp.uni-regensburg.de.
 Ethernet card is A2065 which is found and configured as le0.

 named is not running.
 inetd is running.

 /etc/resolv.conf is empty

 /etc/hostname.le0:
 inet 233.100.1.1 255.255.255.0
 
 /etc/myname:
 tiger

 /etc/hosts:
 233.100.1.1 tiger
 233.100.1.2 mammoth

 ifconfig le0 shows:
 le0: flags=843<UP,BROADCAST,RUNNING,SIMPLEX>
         inet 233.100.1.1 netmask 0xffffff00 broadcast 233.100.1.255
 lo0: flags=8009<UP,LOOPBACK,MULITCAST>
         inet 127.0.0.1 netmask 0xff000000

 netstat -ra:
Internet:
Destination       Gateway          Flags    Refs     Use    Interface
localhost         localhost        UH         2      24     lo0
233.100.1         link#1           UC         0       0     le0
tiger             localhost        UGHS       0      65     lo0

 ls -s `which ifconfig`:
  1 bin bin 91920 Jul 9 13:30 /sbin/ifconfig

 Problem:
I cannot ping 'tiger' nor 233.00.1.1. I can't ping anything on the ethernet.
I only can ping localhost.

What is that SIMPLEX output in ifconfig for? Never seen before.
What is that link#1 output in netstat -ra? Never seen before.

 IP works fine when i use PPP.

What am i missing? I thought i was somehow familar with TCP/IP, but this makes
me feel helpless... Old ifconfig?

 BTW, what are the devices tun0 and eon0 for?

-- 
Markus Illenseer

---

From: Hubert Feyrer <[email-masked]> "Re: ethernet problems" (Sep 6, 10:00pm)

> > Isn't this a class-D address, reserved for multicast?
>
>  255.255.255.0 is for netmask i thought.

Yes, 255.255.255.0 is ok.

>  Can anyone provide a _valid_ hostname.le0 entry please?

Here's dusks's /etc/hostname.le0:
--- X8 --- snip
inet 132.199.15.99 255.255.255.0 132.199.15.255
--- snip --- 8X

>  I feel desperate :-/
>  Any ideas how to debug this problem? netstat is no big help.

I've got a kernel from 940805 sources here, works ok. (Although I go a "dmanext
at end!!!" yesterday :-/). If you want, upload your kernel and I'll check it.

Hubert

-- 
=============== Hubert Feyrer ============================================
      Weekdays: Rennerstr. 19, D-93053 Regensburg,  Tel. 0941/701788
      Weekends: Bachstr. 40,   D-84066 Mallersdorf, Tel. 08772/6084
      Internet: [email-masked] == IRC: hubertf
==========================================================================
    Click <A HREF="http://dusk.rz.uni-regensburg.de/~hubert">here.</A>
                           (soon to be back!:-)