Subject: kernel compile problems

From: bryan collins <[email-masked]>

I'm trying to compile a kernel with src from 12th September, and I get lots of errors
just after typing make.

SOme of the errors as follows:

cpp -DLOCORE -I. -I../../../../arch -I../../../.. -I../../../../sys -DSPHINX -DI
486_CPU -DUCONSOLE -DXSERVER -DTCP_COMPAT_42 -DCOMPAT_43 -DCOMPAT_09 -DCOMPAT_NO
MID -DUSER_LDT -DINET -DKERNFS -DFDESC -DMSDOSFS -DCD9660 -DMROUTING -DMULTICAST
 -DNFSCLIENT -DNFSSERVER -DMFS -DQUOTA -DFFS -DFIFO -DKTRACE -DDEVPAGER -DVNODEP
AGER -DSWAPPAGER -DMACHINE_NONCONTIG -DKERNEL -Di386 ../../i386/locore.s | as  -
o locore.o
sh: warning: running as root with dot in PATH
../../i386/locore.s:144: unterminated character constant
../../i386/locore.s:487: unterminated character constant
../../i386/locore.s:566: unterminated character constant
../../i386/locore.s:1572: unterminated character constant
../../i386/locore.s:1603: unterminated character constant
../../i386/locore.s:1605: unterminated character constant
../../i386/locore.s:1710: unterminated character constant
../../i386/locore.s:1601: unterminated `#if' conditional
as: ../../i386/locore.s:389: operands given don't match any known 386 instructio
n
as: ../../i386/locore.s:598: Rest of line ignored. First ignored character is `s
'.
as: ../../i386/locore.s:598: invalid character '_' in opcode
as: ../../i386/locore.s:621: Rest of line ignored. First ignored character is `f
'
any help would be appreciated.

thanks

bry

P.S is the SB16 with CDROM supported by NetBSD-current?
---

 Bryan Collins
 Coombs Computing Unit
 Australian National University
 Canberra, Australia, 0200
 Tel: (06) 249 3102
 Email: [email-masked]

---

From: "Charles M. Hannum" <[email-masked]>

This could only happen if you're using a different `cpp' or `as' than
the ones supplied in NetBSD.

---

From: "Charles M. Hannum" <[email-masked]>

/usr/libexec should *never* be in your PATH.  You should be using the
`cpp' in /usr/bin.

---

From: [email-masked] (Alistair G. Crooks)

> I'm using binaries compiled from the sept 12th source.
> 
> 102 ~ > file `which cpp`
> /usr/libexec/cpp: NetBSD/i386 demand paged dynamically linked executable
> 103 ~ > file `which as`
> /usr/bin/as: NetBSD/i386 demand paged dynamically linked executable

Can you show us what's on lines 130 (ish) to 160 (ish) of locore.s?

I did get some problems (see the duplicated inode thread) with
certain sources being overwritten by blocks from other files, which
was solved by renaming the corrupted file, and getting a new version
of the file in. But this was immediately obvious from the source
when this happened.

(I didn't report it as a bug, as I thought my hardware was suspect).

Alistair
--
Alistair G. Crooks ([email-masked])			   +44 125 234 6377
Amdahl European HQ, Dogmersfield Park, Hartley Wintney, Hants RG27 8TE, UK.

---

From: Jarle Greipsland <[email-masked]>

bryan collins <[email-masked]> writes:
[ ... ]

> /usr/libexec/cpp: NetBSD/i386 demand paged dynamically linked executable
       ^^^^^^^
Ordinary human beings are not supposed to have /usr/libexec in their PATH,
and certainly not in front of /usr/bin.  If you take a look at
/usr/bin/cpp, the cpp you *should* be using, you'll find that it's a shell
script that tries to convince /usr/libexec/cpp to operate differently than
what it would do by default.  I suggest you reshuffle your PATH and try
again.

					-jarle
----
"My psychiatrist says I have a messiah complex.  But I forgive him."
				-- Jim Carrey